UiPath Documentation
test-cloud
latest
false
Test Cloud admin guide

General troubleshooting

Known issues and solutions for common platform access, certificate, and connectivity problems in Test Cloud.

The remote certificate is invalid because of errors in the certificate chain: UntrustedRoot

The net::ERR_CERT_AUTHORITY_INVALID error occurs when your certificate expires or is involved in a certificate rotation process, indicating that it is now invalid.

It is most likely that the error occurs for the following reasons:

  • You cannot access Test Cloud.
  • Your robot is disconnected.

Figure 1. Your connection is not private warning

Figure 2. UiPath Error message

To fix this error, take the steps, described in the following example:

  1. In a browser window, navigate to your cloud organization via the access URL.

  2. Select the Not secure warning prompt. Then select Certificate is not valid from the dropdown menu.

    Figure 3. Certificate is not valid warning

  3. In the Certificate Viewer, select the Details tab. Then select Export and save the certificate.

    Figure 4. Details tab

  4. On your local machine, open certlm.msc and right-select the Personal folder, then select All Tasks, then select Import. Select the previously generated certificate and import it.

    Figure 5. Importing certificate

  5. In the same certlm.msc window from the previous step, select the Trusted Root Certification Authorities folder, then select All tasks, then select Import. Select the previously generated certificate and import it again.

    Figure 6. Importing certificate

  6. Connect the robot again to check that the error is fixed.

    Select the View site information icon. Select Connection is secure from the dropdown menu.

Browser group policies

Signing in to your Orchestrator service from the Assistant redirects you to the SSO page. In some browsers, you may be prompted to open UiPath Assistant. This happens due to the Assistant's protocol handler not being added to the browser's group policies.

To prevent this behavior, make sure to follow the next steps, depending on the browser (Chrome/Microsoft Edge):

  1. Open Registry Editor.
  2. Navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome/ or Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge, depending on the browser you use.
  3. Add a new key and name it AutoLaunchProtocolsFromOrigins.
  4. Select (Default) to edit the key.
  5. In the Edit String dialog, in the Value data field, add [{"allowed_origins": ["https://myOrchestrator.uipath.com/"],"protocol": "com.uipath.robot.oidc"}] and select OK.
    Important:

    The AutoLaunchProtocolsFromOrigins policy requires Chrome 85 or later.

  6. Close all browser tabs and relaunch the browser.
  7. Verify that your browser applied the new policy by navigating to chrome://policy or edge://policy. The recently added policy should be listed under the Chrome Policies or Microsoft Edge section with the OK status.

Need admin approval when signing in with Microsoft

When users sign in to Test Cloud with the Microsoft sign-in option, Microsoft can block the sign-in with a Need admin approval message. Depending on how your Microsoft Entra ID tenant is configured, the prompt may not include an option to request approval.

This happens when your Microsoft Entra ID tenant restricts user consent to third-party applications. The Microsoft sign-in option uses the UiPath multi-tenant application named UiPath Automation Cloud, with the application (client) ID eb812cb0-7881-44a8-82f7-df95f812e34d. Users from your tenant cannot sign in with Microsoft until an administrator of your tenant allows this application.

Note:

This section applies to the Microsoft sign-in option for UiPath user accounts. The directory-based single sign-on (SSO) integration uses a different application, as described in Microsoft Entra ID integration for Test Cloud and Test Cloud Public Sector.

To allow your users to sign in with Microsoft, an administrator of your Microsoft Entra ID tenant must take one of the following actions in your own tenant:

  • Grant tenant-wide admin consent to the UiPath Automation Cloud application, using the application (client) ID eb812cb0-7881-44a8-82f7-df95f812e34d. For instructions, see Grant tenant-wide admin consent to an application in the Microsoft documentation.
  • Configure the admin consent workflow, which adds a Request approval option to the prompt so that users can request access themselves. For instructions, see Configure the admin consent workflow in the Microsoft documentation.

Was this page helpful?

Connect

Need help? Support

Want to learn? UiPath Academy

Have questions? UiPath Forum

Stay updated