test-manager
latest
false
UiPath logo, featuring letters U and I in white

Test Manager user guide

Last updated Sep 8, 2025

Troubleshooting Test Manager

Cannot use Test Set migrated to Test Manager

Error message

If you attempt to execute a Test Manager test set that was imported from Orchestrator using the Import test sets capability, through a CI/CD pipeline task, then you receive an error specifying that the CI/CD pipeline cannot use the test set because it was migrated to Test Manager.

Solution
To work around this limitation:
  1. Go to the Testing tab in Orchestrator.
  2. Clone the imported test set that you want to execute.
  3. Use the clone for executing the test set through a CI/CD pipeline task instead of the original imported test set.
Note: Cloning a test set does not copy its execution history. To preserve recent execution data within Test Manager, we recommend that you import the cloned test sets into Test Manager after running it via CI/CD.

Automated execution could not start since the package was not found on Orchestrator

Error message

Automated execution could not start since the package was not found on Orchestrator. Only test cases from packages which have been published to Orchestrator can be executed.



Solution

To address this issue, make sure that you have published the package to the Orchestrator Tenant Process Feed.

Test cases could not be executed since no executable versions could be found

Error message

Test cases could not be executed since no executable versions could be found. Only test cases published with the latest package version to Orchestrator can be executed.



Solution

This issue can also be triggered by a test case from your project that is linked to a different Test Manager project. To sort this issue, unlink the automation in Test Manager.

Test set contains test cases from multiple packages

Error message

Unable to execute. Test set contains test cases from multiple packages which is not supported.

Solutions

  1. Duplicated Studio project locally: If you duplicated a Studio project locally by copying the project folder, take the following steps:
    1. Duplicate the faulty test case within Studio.
    2. Delete the original test case from the project.
    3. Re-publish the project to Orchestrator,
  2. No local Studio project duplicated: If you did not duplicate a Studio project locally, relink the faulty test case to the test set.

No license found for Test Manager

Error message

No license found for Test Manager. Functional limitations apply.

Cause

This issue occurs when you enabled the Test Manager platform license, but you don't have a Tester - Named User license.

Solution

To address this issue, ensure that you have a Tester - Named User license assigned to your user account. For more information about licensing for using Test Manager, visit Unified Pricing: Licensing Test Manager.

Was this page helpful?

Get The Help You Need
Learning RPA - Automation Courses
UiPath Community Forum
Uipath Logo
Trust and Security
© 2005-2025 UiPath. All rights reserved.